<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-GB"> <!--<![endif]-->
<head>
    <title>BMA House places itself as a leading London hybrid venue | Event Industry News</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.eventindustrynews.com/xmlrpc.php" />
    <script type="text/javascript">
!function(e){var r={};function n(t){if(r[t])return r[t].exports;var o=r[t]={i:t,l:!1,exports:{}};return e[t].call(o.exports,o,o.exports,n),o.l=!0,o.exports}n.m=e,n.c=r,n.d=function(e,r,t){n.o(e,r)||Object.defineProperty(e,r,{enumerable:!0,get:t})},n.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},n.t=function(e,r){if(1&r&&(e=n(e)),8&r)return e;if(4&r&&"object"==typeof e&&e&&e.__esModule)return e;var t=Object.create(null);if(n.r(t),Object.defineProperty(t,"default",{enumerable:!0,value:e}),2&r&&"string"!=typeof e)for(var o in e)n.d(t,o,function(r){return e[r]}.bind(null,o));return t},n.n=function(e){var r=e&&e.__esModule?function(){return e.default}:function(){return e};return n.d(r,"a",r),r},n.o=function(e,r){return Object.prototype.hasOwnProperty.call(e,r)},n.p="",n(n.s=0)}([function(e,r){!function(e){var r=e.ampUrl,n=e.isCustomizePreview,t=e.isAmpDevMode,o=e.noampQueryVarName,a=e.noampQueryVarValue,i=e.disabledStorageKey,u=e.mobileUserAgents,s=e.regexRegex;if("undefined"!=typeof sessionStorage){var f=new RegExp(s);if(u.some((function(e){var r=e.match(f);if(r&&new RegExp(r[1],r[2]).test(navigator.userAgent))return!0;return navigator.userAgent.includes(e)}))){document.addEventListener("DOMContentLoaded",(function(){var e=document.getElementById("amp-mobile-version-switcher");if(e){e.hidden=!1;var r=e.querySelector("a[href]");r&&r.addEventListener("click",(function(){sessionStorage.removeItem(i)}))}}));var c=t&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(!(sessionStorage.getItem(i)||n||c)){var d=new URL(location.href),l=new URL(r);l.hash=d.hash,d.searchParams.has(o)&&a===d.searchParams.get(o)?sessionStorage.setItem(i,"1"):l.href!==d.href&&(window.stop(),location.replace(l.href))}}}}({"ampUrl":"https:\/\/www.eventindustrynews.com\/features\/top-virtual-venues-bma-house?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}]);
</script>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="TTgMsqrArVw1lEOjxIS2qm5ONAL9Lpjf6OSKJR17tgs" />
<meta name="msvalidate.01" content="DB67711B8843421B5146C5C0EC0FED7D" />
<meta name="p:domain_verify" content="5ab99c77454622a04357dc2698059c96" />
<meta name="yandex-verification" content="2568580059813e70" />
<link rel="icon" type="image/png" href="https://www.eventindustrynews.com/wp-content/uploads/2018/03/EIN-World-News-logo-smallpng-150x150.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.eventindustrynews.com/wp-content/uploads/2018/03/EIN-World-News-logo-smallpng.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.eventindustrynews.com/wp-content/uploads/2018/03/EIN-World-News-logo-smallpng.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.eventindustrynews.com/wp-content/uploads/2018/03/EIN-World-News-logo-smallpng.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.eventindustrynews.com/wp-content/uploads/2018/03/EIN-World-News-logo-smallpng.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.eventindustrynews.com/wp-content/uploads/2018/03/EIN-World-News-logo-smallpng.png"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//792035.smushcdn.com' />
<link rel="alternate" type="application/rss+xml" title="Event Industry News &raquo; Feed" href="https://www.eventindustrynews.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Event Industry News &raquo; Comments Feed" href="https://www.eventindustrynews.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Event Industry News &raquo; BMA House places itself as a leading London hybrid venue Comments Feed" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house/feed" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-132436501-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-132436501-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-132436501-1', {
						allow_anchor:true,forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.eventindustrynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://hb.wpmucdn.com/www.eventindustrynews.com/e11fc9b5-ae93-4e10-bddd-592e6cd08d75.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wphb-1-css'  href='https://hb.wpmucdn.com/www.eventindustrynews.com/61a06396-7a22-4cd0-acf4-be5f4acd957e.css' type='text/css' media='all' />
<style id='wphb-1-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='tdb_front_style-css'  href='https://hb.wpmucdn.com/www.eventindustrynews.com/3a80ae9a-9b82-4930-b80d-0d5b9b45a70f.css' type='text/css' media='all, print' />
<link rel='stylesheet' id='wphb-2-css'  href='https://hb.wpmucdn.com/www.eventindustrynews.com/cb06f966-2d39-44be-aab3-ad73bf43b618.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://hb.wpmucdn.com/www.eventindustrynews.com/7e782031-731b-4a4a-ae19-f9e2ac71289c.css' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.eventindustrynews.com","hash_tracking":"false","ua":"UA-132436501-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.eventindustrynews.com/0f034adc-3792-4e4d-8323-3fd4f26cdbf0.js' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.eventindustrynews.com/53a2a3fc-3689-43ca-a0b9-b1cf2cbe7b4b.js' id='jquery-core-js'></script>
<script type='text/javascript' defer src='https://hb.wpmucdn.com/www.eventindustrynews.com/2439bb43-ec64-46a6-9532-ca26b1dddcc4.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.eventindustrynews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.eventindustrynews.com/wp-json/wp/v2/posts/537196" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.eventindustrynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.eventindustrynews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/p9Msgl-2fKs' />
<link rel="alternate" type="application/json+oembed" href="https://www.eventindustrynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.eventindustrynews.com%2Ffeatures%2Ftop-virtual-venues-bma-house" />
<link rel="alternate" type="text/xml+oembed" href="https://www.eventindustrynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.eventindustrynews.com%2Ffeatures%2Ftop-virtual-venues-bma-house&#038;format=xml" />

<!-- This site is using AdRotate v5.6.4 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gein { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gein img { height:auto; }
	.gein-col { position:relative; float:left; }
	.gein-col:first-child { margin-left: 0; }
	.gein-col:last-child { margin-right: 0; }
	.gein-4 { min-width:0px; max-width:600px; }
	.bein-4 { margin:2px 0px 2px 0px; }
	.gein-5 { min-width:0px; max-width:395px; }
	.bein-5 { margin:0px 0px 0px 0px; }
	.gein-6 { min-width:0px; max-width:600px; }
	.bein-6 { margin:2px 0px 2px 0px; }
	.gein-7 { min-width:0px; max-width:600px; }
	.bein-7 { margin:2px 0px 2px 0px; }
	.gein-8 { min-width:0px; max-width:600px; }
	.bein-8 { margin:2px 0px 2px 0px; }
	.gein-9 { min-width:0px; max-width:600px; }
	.bein-9 { margin:2px 0px 2px 0px; }
	.gein-10 { min-width:0px; max-width:600px; }
	.bein-10 { margin:2px 0px 2px 0px; }
	.gein-11 { min-width:0px; max-width:600px; }
	.bein-11 { margin:2px 0px 2px 0px; }
	.gein-13 { min-width:0px; max-width:395px; }
	.bein-13 { margin:0px 0px 0px 0px; }
	.gein-15 { min-width:0px; max-width:395px; }
	.bein-15 { margin:0px 0px 0px 0px; }
	.gein-19 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.gein-col, .gein-dyn, .gein-single { width:100%; margin-left:0; margin-right:0; }
	}
.adrotate_widgets, .ajdg_bnnrwidgets, .ajdg_grpwidgets { overflow:hidden; padding:0; }
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript" src="https://secure.leadforensics.com/js/81409.js"></script>
<noscript><img src="https://secure.leadforensics.com/81409.png" style="display:none;" /></noscript><!-- SEO meta tags powered by SmartCrawl https://wpmudev.com/project/smartcrawl-wordpress-seo/ -->
<link rel="canonical" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house" />
<meta name="description" content="Home to the British Medical Association since 1925, the sustainable venue boasts 22 unique and versatile spaces for up to 320, including 11 purpose-built meeting rooms, all fitted with cutting edge AV technology. As part of ongoing investment in the services most needed by clients, BMA’s expert ..." />
<meta name="google-site-verification" content="8tQqxSCROXd-ZgqmIuPWxtem3Yoie-gPczTTwDemwR0" />
<meta name="msvalidate.01" content="DB67711B8843421B5146C5C0EC0FED7D" />
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"Organization","@id":"https:\/\/www.eventindustrynews.com\/#schema-publishing-organization","url":"https:\/\/www.eventindustrynews.com","name":"Event Industry News","logo":{"@type":"ImageObject","@id":"https:\/\/www.eventindustrynews.com\/#schema-organization-logo","url":"https:\/\/www.eventindustrynews.com\/wp-content\/uploads\/2018\/03\/EIN-World-News-logo-smallpng.png","height":60,"width":60}},{"@type":"WebSite","@id":"https:\/\/www.eventindustrynews.com\/#schema-website","url":"https:\/\/www.eventindustrynews.com","name":"Event Industry News","encoding":"UTF-8","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.eventindustrynews.com\/search\/{search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https:\/\/www.eventindustrynews.com\/features\/top-virtual-venues-bma-house\/#schema-webpage","isPartOf":{"@id":"https:\/\/www.eventindustrynews.com\/#schema-website"},"publisher":{"@id":"https:\/\/www.eventindustrynews.com\/#schema-publishing-organization"},"url":"https:\/\/www.eventindustrynews.com\/features\/top-virtual-venues-bma-house"},{"@type":"Article","mainEntityOfPage":{"@id":"https:\/\/www.eventindustrynews.com\/features\/top-virtual-venues-bma-house\/#schema-webpage"},"author":{"@type":"Person","@id":"https:\/\/www.eventindustrynews.com\/author\/punchtownparry\/#schema-author","name":"Adam Parry","url":"https:\/\/www.eventindustrynews.com\/author\/punchtownparry","description":"Adam is the co-founder and editor of www.eventindustrynews.com\r\n\r\nAdam, a technology evangelist also organises Event Tech Live, Europe\u2019s only show dedicated to event technology and the Event Technology Awards. Both events take place in November, London."},"publisher":{"@id":"https:\/\/www.eventindustrynews.com\/#schema-publishing-organization"},"dateModified":"2021-03-25T14:44:46","datePublished":"2021-03-25T13:43:18","headline":"BMA House places itself as a leading London hybrid venue | Event Industry News","description":"Home to the British Medical Association since 1925, the sustainable venue boasts 22 unique and versatile spaces for up to 320, including 11 purpose-built meeting rooms, all fitted with cutting edge AV technology. As part of ongoing investment in the services most needed by clients, BMA\u2019s expert ...","name":"BMA House places itself as a leading London hybrid venue","image":{"@type":"ImageObject","@id":"https:\/\/www.eventindustrynews.com\/features\/top-virtual-venues-bma-house\/#schema-article-image","url":"https:\/\/www.eventindustrynews.com\/wp-content\/uploads\/2021\/02\/London-Event-Venue-BMA-House-Courtyard.jpg","height":625,"width":1200},"thumbnailUrl":"https:\/\/www.eventindustrynews.com\/wp-content\/uploads\/2021\/02\/London-Event-Venue-BMA-House-Courtyard.jpg"}]}</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house" />
<meta property="og:title" content="BMA House places itself as a leading London hybrid venue | Event Industry News" />
<meta property="og:description" content="Home to the British Medical Association since 1925, the sustainable venue boasts 22 unique and versatile spaces for up to 320, including 11 purpose-built meeting rooms, all fitted with cutting edge AV technology. As part of ongoing investment in the services most needed by clients, BMA’s expert ..." />
<meta property="og:image" content="https://www.eventindustrynews.com/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="625" />
<meta property="article:published_time" content="2021-03-25T13:43:18" />
<meta property="article:author" content="Adam Parry" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="eventnewsblog" />
<meta name="twitter:title" content="BMA House places itself as a leading London hybrid venue | Event Industry News" />
<meta name="twitter:description" content="Home to the British Medical Association since 1925, the sustainable venue boasts 22 unique and versatile spaces for up to 320, including 11 purpose-built meeting rooms, all fitted with cutting edge AV technology. As part of ongoing investment in the services most needed by clients, BMA’s expert ..." />
<meta name="twitter:image" content="https://www.eventindustrynews.com/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg" />
<!-- /SEO -->
<style type="text/css" id="branda-admin-bar-logo">
body #wpadminbar #wp-admin-bar-wp-logo > .ab-item {
	background-image: url(https://792035.smushcdn.com/1520188/wp-content/uploads/2018/03/EIN-World-News-logo-smallpng.png?lossy=0&strip=1&webp=1);
	background-repeat: no-repeat;
	background-position: 50%;
	background-size: 80%;
}
body #wpadminbar #wp-admin-bar-wp-logo > .ab-item .ab-icon:before {
	content: " ";
}
</style>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"33f09f5b7a","wpRestUrl":"https:\/\/www.eventindustrynews.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.eventindustrynews.com\/wp-admin\/","wpRestNonce":"33f09f5b7a","wpRestUrl":"https:\/\/www.eventindustrynews.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%"};
			</script>
								<!-- Google Analytics tracking code output by Beehive Analytics Pro -->
						<script async src="https://www.googletagmanager.com/gtag/js?id=UA-132436501-1&l=beehiveDataLayer"></script>
		<script>
						window.beehiveDataLayer = window.beehiveDataLayer || [];
			function beehive_ga() {beehiveDataLayer.push(arguments);}
			beehive_ga('js', new Date())
						beehive_ga('config', 'UA-132436501-1', {
				'anonymize_ip': false,
				'allow_google_signals': true,
			})
					</script>
		
<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '2467655106656061', {}, {
    "agent": "wordpress-5.7-3.0.5"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=2467655106656061&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.eventindustrynews.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '2e0fac99-e2c5-473b-9093-0971fec1040a';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.eventindustrynews.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.45da02f8-0e2a-491b-9d85-c6fbaf55a283";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = true;
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="description" content="Home to the British Medical Association since 1925, the sustainable venue boasts 22 unique and versatile spaces for up to 320, including 11 purpose-built meeting rooms, all fitted with cutting edge AV technology. As part of ongoing investment in the services most needed by clients, BMA’s expert technicians have created a range of hybrid and&hellip;" />
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="amphtml" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?amp"><style>#amp-mobile-version-switcher {
	position: absolute;
	width: 100%;
	left: 0;
	z-index: 100;
}

#amp-mobile-version-switcher > a {
	display: block;
	padding: 15px 0;
	font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Oxygen-Sans, Ubuntu, Cantarell, "Helvetica Neue", sans-serif;
	font-size: 16px;
	font-weight: 600;
	color: #eaeaea;
	text-align: center;
	text-decoration: none;
	background-color: #444;
	border: 0;
}

#amp-mobile-version-switcher > a:hover,
#amp-mobile-version-switcher > a:focus,
#amp-mobile-version-switcher > a:active {
	text-decoration: underline;
}
</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?amp=1">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content=" BMA House places itself as a leading London hybrid venue - Event Industry News" />
<meta property="og:url" content="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house" />
<meta property="og:description" content="Home to the British Medical Association since 1925, the sustainable venue boasts 22 unique and versatile spaces for up to 320, including 11 purpose-built meeting rooms, all fitted with cutting edge…" />
<meta property="article:published_time" content="2021-03-25T13:43:18+00:00" />
<meta property="article:modified_time" content="2021-03-25T14:44:46+00:00" />
<meta property="og:site_name" content="Event Industry News" />
<meta property="og:image" content="https://www.eventindustrynews.com/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="625" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:site" content="@eventnewsblog" />
<meta name="twitter:text:title" content="BMA House places itself as a leading London hybrid venue" />
<meta name="twitter:image" content="https://www.eventindustrynews.com/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-132436501-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-132436501-1');
</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.eventindustrynews.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.eventindustrynews.com/category/features",
                    "name": "Features"
                }
            }    
        ]
    }
</script>

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #e85f36;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #e85f36;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #e85f36;
                }
                .tdm-btn-style1 {
					background-color: #e85f36;
				}
				.tdm-btn-style2:before {
				    border-color: #e85f36;
				}
				.tdm-btn-style2 {
				    color: #e85f36;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #e85f36;
                    -moz-box-shadow: 0 2px 16px #e85f36;
                    box-shadow: 0 2px 16px #e85f36;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #e85f36;
                    -moz-box-shadow: 0 4px 26px #e85f36;
                    box-shadow: 0 4px 26px #e85f36;
				}
</style>

<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-132436501-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-537196 single-format-standard td-standard-pack top-virtual-venues-bma-house global-block-template-1 wpb-js-composer js-comp-ver-6.6.0 vc_responsive td-boxed-layout td-background-link" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/eventindustrynewsuk/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/eventindustrynews/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company/event-industry-news/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/EventNewsBlog" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCizuO_XW57Uq4uUQ9BKdjPA" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-38604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first menu-item-38604"><a href="https://www.eventindustrynews.com/category/news">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-38600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38600"><a href="https://www.eventindustrynews.com/category/news/brand-agencies">Brand &amp; Agencies</a></li>
	<li id="menu-item-39141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39141"><a href="https://www.eventindustrynews.com/category/news/concert-touring">Concert &amp; Touring</a></li>
	<li id="menu-item-38596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38596"><a href="https://www.eventindustrynews.com/category/news/conference-news">Conference News</a></li>
	<li id="menu-item-38597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38597"><a href="https://www.eventindustrynews.com/category/news/event-technology">Event Technology</a></li>
	<li id="menu-item-38599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38599"><a href="https://www.eventindustrynews.com/category/news/exhibition-news">Exhibition News</a></li>
	<li id="menu-item-38598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38598"><a href="https://www.eventindustrynews.com/category/news/festival-outdoors">Festival &amp; Outdoors</a></li>
	<li id="menu-item-38601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38601"><a href="https://www.eventindustrynews.com/category/news/event-industry-recruitment">Recruitment News</a></li>
</ul>
</li>
<li id="menu-item-42829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-42829"><a href="https://www.eventindustrynews.com/">Regions<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-42830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42830"><a href="https://www.eventindustrynews.com/category/news/uk-and-europe">UK and Europe</a></li>
	<li id="menu-item-42831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42831"><a href="https://www.eventindustrynews.com/category/news/us-and-canada-event-industry-news">US and Canada</a></li>
</ul>
</li>
<li id="menu-item-4859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4859"><a href="https://www.eventindustrynews.com/category/spotlights">Spotlights<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-39007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39007"><a href="https://www.eventindustrynews.com/category/spotlights/agency-spotlights">Agency Spotlights</a></li>
	<li id="menu-item-39008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39008"><a href="https://www.eventindustrynews.com/category/spotlights/event-tech-spotlights">Event Tech Spotlights</a></li>
	<li id="menu-item-39009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39009"><a href="https://www.eventindustrynews.com/category/spotlights/venue-spotlights">Venue Spotlights</a></li>
</ul>
</li>
<li id="menu-item-3432" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3432"><a href="https://www.eventindustrynews.com/category/features">Features</a></li>
<li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116"><a href="https://www.eventindustrynews.com/category/guest-blogs">Blogs</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.eventindustrynews.com/category/podcasts">Podcasts</a></li>
<li id="menu-item-115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115"><a href="https://www.eventindustrynews.com/category/ein-tv">Videos</a></li>
<li id="menu-item-38082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-38082"><a href="https://www.eventindustrynews.com/category/event-industry-job-vacancies">Jobs<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-38083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38083"><a href="https://www.eventindustrynews.com/category/news/event-industry-recruitment">Recruitment News</a></li>
</ul>
</li>
<li id="menu-item-120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-120"><a href="https://www.eventindustrynews.com/directory">Directory</a></li>
<li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117"><a href="https://www.eventindustrynews.com/category/guides">Guides</a></li>
<li id="menu-item-44252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44252"><a href="https://forms.gle/xfegsJ9GfJFvUd1u9">Subscribe</a></li>
<li id="menu-item-41343" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41343"><a href="https://www.eventindustrynews.com/event-industry-events">Events</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                <a id="signin-register-link-mob">Create an account</a>
	                </div>
	                
	                <div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.eventindustrynews.com/privacy-policy">Privacy Policy</a></div>

                </div>
            </div>

            
            
            
            <div id="td-register-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-register-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign up</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
            	<div class="td-login-panel-title"><span>Welcome!</span>Register for an account</div>
                <div class="td-login-form-wrap">
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email-mob" value="" required><label>your email</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user-mob" value="" required><label>your username</label></div>
	                <input type="button" name="register_button" id="register_button-mob" class="td-login-button" value="REGISTER">
	                <div class="td-login-info-text">A password will be e-mailed to you.</div>
	                <div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.eventindustrynews.com/privacy-policy">Privacy Policy</a></div>
                </div>
            </div>
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.eventindustrynews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 1
-->


<div class="td-header-wrap td-header-style-1 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-top-orange" class="top-header-menu"><li id="menu-item-87" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-87"><a href="https://www.eventindustrynews.com/about-event-industry-news">About</a></li>
<li id="menu-item-88" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-88"><a href="https://www.eventindustrynews.com/advertising-event-marketing">Advertising</a></li>
<li id="menu-item-246994" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-246994"><a href="https://www.eventindustrynews.com/article-submissions">Article Submissions</a></li>
<li id="menu-item-31854" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-31854"><a href="https://www.eventindustrynews.com/media-pack">Media Pack</a></li>
<li id="menu-item-377" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-377"><a href="https://www.eventindustrynews.com/contact-event-industry-news">Contact</a></li>
<li id="menu-item-600" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-600"><a href="https://www.eventindustrynews.com/cookie-policy">Cookie Policy</a></li>
<li id="menu-item-601" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-601"><a href="https://www.eventindustrynews.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-602" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-602"><a href="https://www.eventindustrynews.com/terms-of-service">Terms of Service</a></li>
<li id="menu-item-44254" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-44254"><a href="https://forms.gle/xfegsJ9GfJFvUd1u9">Subscribe to newsletters</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/eventindustrynewsuk/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/eventindustrynews/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company/event-industry-news/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/EventNewsBlog" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCizuO_XW57Uq4uUQ9BKdjPA" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            <a id="register-link">Create an account</a>
                            <div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.eventindustrynews.com/privacy-policy">Privacy Policy</a></div>
                        </div>

                        
                <div id="td-register-div" class="td-login-form-div td-display-none">
                    <div class="td-login-panel-title">Create an account</div>
                    <div class="td-login-panel-descr">Welcome! Register for an account</div>
                    <div class="td_display_err"></div>
                    <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email" value="" required><label>your email</label></div>
                    <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user" value="" required><label>your username</label></div>
                    <input type="button" name="register_button" id="register_button" class="wpb_button btn td-login-button" value="Register">
                    <div class="td-login-info-text">A password will be e-mailed to you.</div>
                    <div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.eventindustrynews.com/privacy-policy">Privacy Policy</a></div>
                </div>

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="https://www.eventindustrynews.com/">
            <img class="td-retina-data" data-retina="https://www.eventindustrynews.com/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?lossy=0&strip=1&webp=1" alt="Event Industry News Logo" title="Event Industry News Logo" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?size=139x55&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-300x119.png?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?size=417x165&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?size=556x220&lossy=0&strip=1&webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-696x276.png?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-768x305.png?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-1024x406.png?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-1059x420.png?lossy=0&strip=1&webp=1 1059w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-1068x424.png?lossy=0&strip=1&webp=1 1068w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?lossy=0&strip=1&webp=1 1160w" sizes="(max-width: 1160px) 100vw, 1160px" />
            <span class="td-visual-hidden">Event Industry News</span>
        </a>
                </div>
                            <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  tdi_1_541 td_block_template_1">
<style>
/* custom css */
.tdi_1_541.td-a-rec{
					text-align: center;
				}.tdi_1_541 .td-element-style{
					z-index: -1;
				}.tdi_1_541.td-a-rec-img{
				    text-align: left;
				}.tdi_1_541.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_541.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><span class="td-adspot-title">Advertisement</span><div class="gein gein-1"><div class="gein-single aein-222"><a class="gofollow" data-track="MjIyLDEsMSw2MA==" href="https://bit.ly/3ko41wT"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Top-Right-MPU.gif?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Top-Right-MPU.gif?lossy=0&strip=1&webp=1 700w,https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Top-Right-MPU.gif?size=139x20&lossy=0&strip=1&webp=1 139w,https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Top-Right-MPU.gif?size=278x40&lossy=0&strip=1&webp=1 278w,https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Top-Right-MPU.gif?size=417x60&lossy=0&strip=1&webp=1 417w,https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Top-Right-MPU.gif?size=556x79&lossy=0&strip=1&webp=1 556w" sizes="(max-width: 700px) 100vw, 700px" /></a></div></div></div>
</div>                </div>
                    </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
                <a class="td-main-logo" href="https://www.eventindustrynews.com/">
            <img class="td-retina-data" data-retina="https://www.eventindustrynews.com/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?lossy=0&strip=1&webp=1" alt="Event Industry News Logo" title="Event Industry News Logo" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?size=139x55&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-300x119.png?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?size=417x165&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?size=556x220&lossy=0&strip=1&webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-696x276.png?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-768x305.png?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-1024x406.png?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-1059x420.png?lossy=0&strip=1&webp=1 1059w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3-1068x424.png?lossy=0&strip=1&webp=1 1068w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png?lossy=0&strip=1&webp=1 1160w" sizes="(max-width: 1160px) 100vw, 1160px" />
        </a>
        </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-38604"><a href="https://www.eventindustrynews.com/category/news">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38600"><a href="https://www.eventindustrynews.com/category/news/brand-agencies">Brand &amp; Agencies</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39141"><a href="https://www.eventindustrynews.com/category/news/concert-touring">Concert &amp; Touring</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38596"><a href="https://www.eventindustrynews.com/category/news/conference-news">Conference News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38597"><a href="https://www.eventindustrynews.com/category/news/event-technology">Event Technology</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38599"><a href="https://www.eventindustrynews.com/category/news/exhibition-news">Exhibition News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38598"><a href="https://www.eventindustrynews.com/category/news/festival-outdoors">Festival &amp; Outdoors</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38601"><a href="https://www.eventindustrynews.com/category/news/event-industry-recruitment">Recruitment News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children td-menu-item td-normal-menu menu-item-42829"><a href="https://www.eventindustrynews.com/">Regions</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-42830"><a href="https://www.eventindustrynews.com/category/news/uk-and-europe">UK and Europe</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-42831"><a href="https://www.eventindustrynews.com/category/news/us-and-canada-event-industry-news">US and Canada</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4859"><a href="https://www.eventindustrynews.com/category/spotlights">Spotlights</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39007"><a href="https://www.eventindustrynews.com/category/spotlights/agency-spotlights">Agency Spotlights</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39008"><a href="https://www.eventindustrynews.com/category/spotlights/event-tech-spotlights">Event Tech Spotlights</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39009"><a href="https://www.eventindustrynews.com/category/spotlights/venue-spotlights">Venue Spotlights</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-3432"><a href="https://www.eventindustrynews.com/category/features">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-116"><a href="https://www.eventindustrynews.com/category/guest-blogs">Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-112"><a href="https://www.eventindustrynews.com/category/podcasts">Podcasts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-115"><a href="https://www.eventindustrynews.com/category/ein-tv">Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-38082"><a href="https://www.eventindustrynews.com/category/event-industry-job-vacancies">Jobs</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38083"><a href="https://www.eventindustrynews.com/category/news/event-industry-recruitment">Recruitment News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-120"><a href="https://www.eventindustrynews.com/directory">Directory</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-117"><a href="https://www.eventindustrynews.com/category/guides">Guides</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-44252"><a href="https://forms.gle/xfegsJ9GfJFvUd1u9">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-41343"><a href="https://www.eventindustrynews.com/event-industry-events">Events</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://www.eventindustrynews.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

</div>
            </div>

            
    <div class="td-main-content-wrap td-container-wrap">

        <div class="td-container td-post-template-default ">
            <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.eventindustrynews.com/">Home</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Features</span></div></div>

            <div class="td-pb-row">
                                        <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-537196" class="post-537196 post type-post status-publish format-standard has-post-thumbnail category-features tag-bma-house tag-event-industry-news tag-virtual-venues" itemscope itemtype="https://schema.org/Article"47>
        <div class="td-post-header">

            <!-- category -->
            <header class="td-post-title">
                <h1 class="entry-title">BMA House places itself as a leading London hybrid venue</h1>
                

                <div class="td-module-meta-info">
                    <!-- author --><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.eventindustrynews.com/author/punchtownparry">Adam Parry</a><div class="td-author-line"> - </div> </div>                    <!-- date --><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-25T13:43:18+00:00" >25th March 2021</time></span>                    <!-- comments -->                    <!-- views --><div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-537196">276</span></div>                </div>

            </header>

        </div>

        
        <div class="td-post-content tagdiv-type">
            <!-- image --><div class="td-post-featured-image"><a href="https://www.eventindustrynews.com/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg" data-caption=""><img width="696" height="363" class="entry-thumb td-modal-image" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard-696x363.jpg?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg?size=139x72&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard-300x156.jpg?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg?size=417x217&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg?size=556x290&lossy=0&strip=1&webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard-696x363.jpg?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard-768x400.jpg?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard-806x420.jpg?lossy=0&strip=1&webp=1 806w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard-1024x533.jpg?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard-1068x556.jpg?lossy=0&strip=1&webp=1 1068w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg?lossy=0&strip=1&webp=1 1200w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="London-Event-Venue-BMA-House-Courtyard"/></a></div>
            <!-- content -->
<p><strong>Home to the British Medical Association since 1925, <a href="https://bmahouse.org.uk/" target="_blank" rel="noreferrer noopener">the sustainable venue</a> boasts 22 unique and versatile spaces for up to 320, including 11 purpose-built meeting rooms, all fitted with cutting edge AV technology.</strong></p>



<p>As part of ongoing investment in the services most needed by clients, BMA’s expert technicians have created a range of <a href="https://bmahouse.org.uk/wp-content/uploads/2020/11/BMA-Virtual-and-Hybrid-Events-Packages.pdf" target="_blank" rel="noreferrer noopener">hybrid and digital event packages</a> that reflect ongoing changes in the corporate and association meeting industry.&nbsp;These upgrades will ensure BMA House’s place as a leading London hybrid venue.</p>



<p>Their flagship space, <a href="https://bmahouse.org.uk/conferences-meetings/the-great-hall/" target="_blank" rel="noreferrer noopener">the Great Hall</a>, will soon be kitted out with its very own impressive Hybrid Virtual Studio. A bespoke, custom-build to fit their Great Hall, the Studio is one of its kind and includes a prominent 20ft wide by 10ft height Green Screen, with fully customisable background, 4 x PTZ HD camera set-up, streaming PC, VMix 4k Pro Software, relay monitors and professional lighting to cater for all your studio needs.</p>



<p>Including options for webcasting, breakouts, speaker only conferences and exhibitor/sponsor packages, the offering reflects both the challenges presented by COVID-19 and the future needs of event organisers.</p><div class="td-a-rec td-a-rec-id-content_inline  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp tdi_2_010 td_block_template_1">
<style>
/* custom css */
.tdi_2_010.td-a-rec{
					text-align: center;
				}.tdi_2_010 .td-element-style{
					z-index: -1;
				}.tdi_2_010.td-a-rec-img{
				    text-align: left;
				}.tdi_2_010.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2_010.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><span class="td-adspot-title">Advertisement</span><div class="gein gein-19"><div class="gein-single aein-71"><a class="gofollow" data-track="NzEsMTksMSw2MA==" href="http://bit.ly/2KvOV8D"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours.jpg?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours.jpg?size=139x88&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours-300x190.jpg?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours.jpg?size=417x264&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours-600x380.jpg?lossy=0&strip=1&webp=1 600w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours-663x420.jpg?lossy=0&strip=1&webp=1 663w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours-696x441.jpg?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours-768x486.jpg?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours-1024x649.jpg?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/master_concerts_tours.jpg?lossy=0&strip=1&webp=1 1053w" sizes="(max-width: 1053px) 100vw, 1053px" /></a></div></div></div>



<p><strong>Highlights from the packages include:</strong></p>



<ul><li>Webcasting – fully branded live streaming platform with up to 2,000 viewing hours of content. Created using professional cameras and sound suite managed by two technicians.</li><li>Fully Equipped TV Studio Layout including – Interview/chat style set up, sales or product launches, conferences/meetings, AGM’s etc. All with the ability to bring in remote guests to feature in the event.</li><li>Fully Virtual – Including a fully brandable Teams/Teams live solution and GotoWebinar&nbsp;platform.</li><li>Dedicated technical support – taking the pressure off event organisers to ensure a smooth-running hybrid event from start to finish.</li><li>Breakout sessions – available direct from main sessions or via bespoke joining links. Full presentation setup with Q&amp;A and interaction for up to 250 delegates.</li><li>Exhibitor and Sponsor spotlights – interactive demonstrations, virtual pitches and scheduled Q&amp;A sessions. Run live or created in advance by professional film and edit teams.</li><li>Fully digital meetings – facilitated by BMA’s technical experts and capable of hosting virtual events for up to 2,000, this option takes away the hassle and challenges of running a digital event, allowing organisers to focus on the content.</li></ul>



<div class="wp-block-image"><figure class="aligncenter size-large"><a href="https://www.eventindustrynews.com/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7.jpg" target="_blank" rel="noopener"><img loading="lazy" width="1000" height="636" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7.jpg?lossy=0&strip=1&webp=1" alt="" class="wp-image-537228" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7.jpg?size=139x88&amp;lossy=0&amp;strip=1&amp;webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7-300x191.jpg?lossy=0&amp;strip=1&amp;webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7.jpg?size=417x265&amp;lossy=0&amp;strip=1&amp;webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7.jpg?size=556x354&amp;lossy=0&amp;strip=1&amp;webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7-660x420.jpg?lossy=0&amp;strip=1&amp;webp=1 660w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7-696x443.jpg?lossy=0&amp;strip=1&amp;webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7-768x488.jpg?lossy=0&amp;strip=1&amp;webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Theatre-Great-Hall-7.jpg?lossy=0&amp;strip=1&amp;webp=1 1000w" sizes="(max-width: 696px) 100vw, 696px" /></a></figure></div>



<p><a href="https://bmahouse.org.uk/sustainability/" target="_blank" rel="noreferrer noopener">Sustainability</a> is a way of life for the team at BMA House, adopting green initiatives is essential, not only for themselves but for their clients, suppliers and events. As part of an ongoing drive to ensure their event spaces provide top of the range technology, BMA House will also guarantee this is carried out in the most sustainable way, keeping a delegate’s carbon footprint as low as possible. In essence, they are delivering the perfect balance between sustainability and technology.</p>



<p>Digital and hybrid solutions offer a new take on the concept of sustainable events. Digital only events have a far lower impact on the world around us as travel decreases. In addition, hybrid events allow event planners to market to a wider audience, bringing in more people both domestically and internationally for (relatively) little cost, helping to increase attendee numbers on the day and create an overall more engaging event.</p>



<p>For further information on hybrid and digital event options at BMA House, please contact the events team on <a href="mailto:events@bma.org.uk">events@bma.org.uk</a>&nbsp;/ 020 7874 7020 or visit&nbsp;<a href="http://www.bmahouse.org.uk/" target="_blank" rel="noreferrer noopener">http://www.bmahouse.org.uk/</a>&nbsp;</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><a href="http://bit.ly/BMAHouse" target="_blank" rel="noopener"><img loading="lazy" width="1024" height="256" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-1024x256.jpg?lossy=0&strip=1&webp=1" alt="" class="wp-image-537203" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House.jpg?size=139x35&amp;lossy=0&amp;strip=1&amp;webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-300x75.jpg?lossy=0&amp;strip=1&amp;webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House.jpg?size=417x104&amp;lossy=0&amp;strip=1&amp;webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House.jpg?size=556x139&amp;lossy=0&amp;strip=1&amp;webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-696x174.jpg?lossy=0&amp;strip=1&amp;webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-768x192.jpg?lossy=0&amp;strip=1&amp;webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-1024x256.jpg?lossy=0&amp;strip=1&amp;webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-1068x267.jpg?lossy=0&amp;strip=1&amp;webp=1 1068w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-1536x384.jpg?lossy=0&amp;strip=1&amp;webp=1 1536w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-1681x420.jpg?lossy=0&amp;strip=1&amp;webp=1 1681w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-1920x480.jpg?lossy=0&amp;strip=1&amp;webp=1 1920w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Banner-advert-800px-x-200px-–-BMA-House-scaled.jpg?lossy=0&amp;strip=1&amp;webp=1 2048w" sizes="(max-width: 696px) 100vw, 696px" /></a></figure></div>



<ul class="wp-block-social-links"><li class="wp-social-link wp-social-link-facebook wp-block-social-link"><a href="https://www.facebook.com/BMAHouse/" aria-label="Facebook"  class="wp-block-social-link-anchor"> <svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" role="img" aria-hidden="true" focusable="false"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>

<li class="wp-social-link wp-social-link-twitter wp-block-social-link"><a href="https://twitter.com/bmahousevenue" aria-label="Twitter"  class="wp-block-social-link-anchor"> <svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" role="img" aria-hidden="true" focusable="false"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>

<li class="wp-social-link wp-social-link-instagram wp-block-social-link"><a href="https://www.instagram.com/bmahousevenue/" aria-label="Instagram"  class="wp-block-social-link-anchor"> <svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" role="img" aria-hidden="true" focusable="false"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>

<li class="wp-social-link wp-social-link-linkedin wp-block-social-link"><a href="https://www.linkedin.com/company/bma-house/" aria-label="LinkedIn"  class="wp-block-social-link-anchor"> <svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" role="img" aria-hidden="true" focusable="false"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z"></path></svg></a></li></ul>



<p class="has-text-align-center"><em>SPONSORED CONTENT</em></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-537196" class="share-facebook sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-537196" class="share-linkedin sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-537196" class="share-twitter sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-537196" class="share-pinterest sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-537196" class="share-skype sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>        </div>

        <footer>
            <!-- post pagination -->            <!-- review -->
            <div class="td-post-source-tags">
                <!-- source via -->                <!-- tags --><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.eventindustrynews.com/tag/bma-house">BMA House</a></li><li><a href="https://www.eventindustrynews.com/tag/event-industry-news">Event Industry News</a></li><li><a href="https://www.eventindustrynews.com/tag/virtual-venues">Virtual Venues</a></li></ul>            </div>

                        <!-- next prev -->            <!-- author box --><div class="author-box-wrap"><a href="https://www.eventindustrynews.com/author/punchtownparry"><img alt='' src='https://secure.gravatar.com/avatar/695c026427c5239ea3c356e91d4e3cc2?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/695c026427c5239ea3c356e91d4e3cc2?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.eventindustrynews.com/author/punchtownparry">Adam Parry</a></span></div><div class="td-author-description">Adam is the co-founder and editor of www.eventindustrynews.com

Adam, a technology evangelist also organises Event Tech Live, Europe’s only show dedicated to event technology and the Event Technology Awards. Both events take place in November, London.</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/adam.parry" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/in/adamparry/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/punchtownparry" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>            <!-- meta --><span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Adam Parry"></span><meta itemprop="datePublished" content="2021-03-25T13:43:18+00:00"><meta itemprop="dateModified" content="2021-03-25T14:44:46+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.eventindustrynews.com/wp-content/uploads/2020/06/28516228_1568560926532727_3505708840230974864_o-3.png"></span><meta itemprop="name" content="Event Industry News"></span><meta itemprop="headline " content="BMA House places itself as a leading London hybrid venue"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.eventindustrynews.com/wp-content/uploads/2021/02/London-Event-Venue-BMA-House-Courtyard.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="625"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts tdi_3_1c1 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_3_1c1" ><script>var block_tdi_3_1c1 = new tdBlock();
block_tdi_3_1c1.id = "tdi_3_1c1";
block_tdi_3_1c1.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3_1c1","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":537196,"live_filter_cur_post_author":"1","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3_1c1","tdc_css_class_style":"tdi_3_1c1_rand_style"}';
block_tdi_3_1c1.td_column_number = "3";
block_tdi_3_1c1.block_type = "td_block_related_posts";
block_tdi_3_1c1.post_count = "3";
block_tdi_3_1c1.found_posts = "236";
block_tdi_3_1c1.header_color = "";
block_tdi_3_1c1.ajax_pagination_infinite_stop = "";
block_tdi_3_1c1.max_num_pages = "79";
tdBlocksArray.push(block_tdi_3_1c1);
</script><h4 class="td-related-title td-block-title"><a id="tdi_4_00c" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3_1c1" href="#">RELATED ARTICLES</a><a id="tdi_5_851" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3_1c1" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3_1c1 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.eventindustrynews.com/features/10-11-carlton-house-terrace-creates-carlton-virtual-studio" rel="bookmark" class="td-image-wrap " title="10-11 Carlton House Terrace creates Carlton Virtual Studio" ><img width="218" height="150" class="entry-thumb" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/10-11-CHT-studio-shot-1200x900-1-218x150.png?lossy=0&strip=1&webp=1"  srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/10-11-CHT-studio-shot-1200x900-1.png?size=43x30&lossy=0&strip=1&webp=1 43w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/10-11-CHT-studio-shot-1200x900-1-100x70.png?lossy=0&strip=1&webp=1 100w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/10-11-CHT-studio-shot-1200x900-1-218x150.png?lossy=0&strip=1&webp=1 218w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="10-11 Carlton House Terrace creates Carlton Virtual Studio" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.eventindustrynews.com/features/10-11-carlton-house-terrace-creates-carlton-virtual-studio" rel="bookmark" title="10-11 Carlton House Terrace creates Carlton Virtual Studio">10-11 Carlton House Terrace creates Carlton Virtual Studio</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.eventindustrynews.com/features/the-convention-centre-dublin-the-ccd" rel="bookmark" class="td-image-wrap " title="The Convention Centre Dublin (The CCD)" ><img width="218" height="150" class="entry-thumb" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/03/Events-guide-option-3-218x150.png?lossy=0&strip=1&webp=1"  srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/03/Events-guide-option-3.png?size=43x30&lossy=0&strip=1&webp=1 43w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/03/Events-guide-option-3-100x70.png?lossy=0&strip=1&webp=1 100w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/03/Events-guide-option-3-218x150.png?lossy=0&strip=1&webp=1 218w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="The Convention Centre Dublin (The CCD)" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.eventindustrynews.com/features/the-convention-centre-dublin-the-ccd" rel="bookmark" title="The Convention Centre Dublin (The CCD)">The Convention Centre Dublin (The CCD)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.eventindustrynews.com/features/ensure-the-show-can-still-go-on-with-sterling-studio" rel="bookmark" class="td-image-wrap " title="Ensure the show can still go on with Sterling Studio" ><img width="218" height="150" class="entry-thumb" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Sterling-Event-Group-featured-218x150.jpg?lossy=0&strip=1&webp=1"  srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Sterling-Event-Group-featured.jpg?size=43x30&lossy=0&strip=1&webp=1 43w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Sterling-Event-Group-featured-100x70.jpg?lossy=0&strip=1&webp=1 100w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/02/Sterling-Event-Group-featured-218x150.jpg?lossy=0&strip=1&webp=1 218w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Ensure the show can still go on with Sterling Studio" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.eventindustrynews.com/features/ensure-the-show-can-still-go-on-with-sterling-studio" rel="bookmark" title="Ensure the show can still go on with Sterling Studio">Ensure the show can still go on with Sterling Studio</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_3_1c1" data-td_block_id="tdi_3_1c1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_3_1c1" data-td_block_id="tdi_3_1c1"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
        <div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/features/top-virtual-venues-bma-house#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="td-login-modal-js" data-effect="mpf-td-login-effect" href="#login-form">Log in to leave a comment </a></p>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>    </div> <!-- /.content -->
                                </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="td_block_template_1 widget ajdg_grpwidgets"><h4 class="block-title"><span>Advertisement</span></h4><span style="font-weight: bold; color: #f00;">Error, no group ID set! Check your syntax!</span></aside><aside class="td_block_template_1 extendedwopts-hide extendedwopts-mobile widget ajdg_grpwidgets"><div class="gein gein-15"><div class="gein-col bein-15 aein-202"><a class="gofollow" data-track="MjAyLDE1LDEsNjA=" href="https://bit.ly/2XnBo8Y"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01.jpg?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01.jpg?size=139x88&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01-300x190.jpg?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01.jpg?size=417x264&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01.jpg?size=556x352&lossy=0&strip=1&webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01-664x420.jpg?lossy=0&strip=1&webp=1 664w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01-696x440.jpg?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01-768x486.jpg?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01-1024x648.jpg?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/08/sidetile_cbg_vcg_2020_1-01.jpg?lossy=0&strip=1&webp=1 1054w" sizes="(max-width: 1054px) 100vw, 1054px" /></a></div></div><div class="gein gein-15"><div class="gein-col bein-15 aein-214"><a class="gofollow" data-track="MjE0LDE1LDEsNjA=" href="https://view.publitas.com/event-industry-news/event-tech-buyers-guide-2021/page/1"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile.jpg?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile.jpg?size=139x88&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile-300x190.jpg?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile.jpg?size=417x264&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile.jpg?size=556x352&lossy=0&strip=1&webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile-664x420.jpg?lossy=0&strip=1&webp=1 664w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile-696x440.jpg?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile-768x486.jpg?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile-1024x648.jpg?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/11/etbg21_socials__download_now_sidetile.jpg?lossy=0&strip=1&webp=1 1054w" sizes="(max-width: 1054px) 100vw, 1054px" /></a></div></div><div class="gein gein-15"><div class="gein-col bein-15 aein-189"><a class="gofollow" data-track="MTg5LDE1LDEsNjA=" href="https://bit.ly/dbpixelhousevirtual"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/07/Pixelhub-tile_.png?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2020/07/Pixelhub-tile_.png?size=139x88&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/07/Pixelhub-tile_-300x190.png?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2020/07/Pixelhub-tile_.png?lossy=0&strip=1&webp=1 396w" sizes="(max-width: 396px) 100vw, 396px" /></a></div></div><div class="gein gein-15"><div class="gein-col bein-15 aein-223"><a class="gofollow" data-track="MjIzLDE1LDEsNjA=" href="https://www.eventtechlive.com"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile.jpg?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile.jpg?size=139x88&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-300x190.jpg?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile.jpg?size=417x264&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile.jpg?size=556x352&lossy=0&strip=1&webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-663x420.jpg?lossy=0&strip=1&webp=1 663w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-696x441.jpg?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-768x487.jpg?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1024x649.jpg?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile.jpg?lossy=0&strip=1&webp=1 1054w" sizes="(max-width: 1054px) 100vw, 1054px" /></a></div></div><div class="gein gein-15"><div class="gein-col bein-15 aein-66"><a class="gofollow" data-track="NjYsMTUsMSw2MA==" href="http://bit.ly/2KvOV8D"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/Novum-General-Banner.gif?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/Novum-General-Banner.gif?lossy=0&strip=1&webp=1 790w,https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/Novum-General-Banner.gif?size=139x88&lossy=0&strip=1&webp=1 139w,https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/Novum-General-Banner.gif?size=278x176&lossy=0&strip=1&webp=1 278w,https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/Novum-General-Banner.gif?size=417x264&lossy=0&strip=1&webp=1 417w,https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/Novum-General-Banner.gif?size=556x352&lossy=0&strip=1&webp=1 556w,https://792035.smushcdn.com/1520188/wp-content/uploads/2019/03/Novum-General-Banner.gif?size=696x441&lossy=0&strip=1&webp=1 696w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div><div class="gein gein-15"><div class="gein-col bein-15 aein-224"><a class="gofollow" data-track="MjI0LDE1LDEsNjA=" href="https://www.eventtechlive.com"><img src="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1.jpg?lossy=0&strip=1&webp=1" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1.jpg?size=139x88&lossy=0&strip=1&webp=1 139w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1-300x190.jpg?lossy=0&strip=1&webp=1 300w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1.jpg?size=417x264&lossy=0&strip=1&webp=1 417w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1.jpg?size=556x352&lossy=0&strip=1&webp=1 556w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1-663x420.jpg?lossy=0&strip=1&webp=1 663w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1-696x441.jpg?lossy=0&strip=1&webp=1 696w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1-768x487.jpg?lossy=0&strip=1&webp=1 768w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1-1024x649.jpg?lossy=0&strip=1&webp=1 1024w, https://792035.smushcdn.com/1520188/wp-content/uploads/2021/01/etl21_us_uk__side_tile-1.jpg?lossy=0&strip=1&webp=1 1054w" sizes="(max-width: 1054px) 100vw, 1054px" /></a></div></div></aside>                            </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
        </div> <!-- /.td-container -->
    </div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-4 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.eventindustrynews.com/"><img class="td-retina-data" src="https://792035.smushcdn.com/1520188/wp-content/uploads/2018/03/EIN-2016_RGB-White01-300x119.png?lossy=0&strip=1&webp=1" data-retina="https://www.eventindustrynews.com/wp-content/uploads/2018/03/EIN-2016_RGB-White01-300x119.png" alt="Event Industry News Logo" title="Event Industry News Logo" width="" srcset="https://792035.smushcdn.com/1520188/wp-content/uploads/2018/03/EIN-2016_RGB-White01-300x119.png?lossy=0&strip=1&webp=1 300w,https://792035.smushcdn.com/1520188/wp-content/uploads/2018/03/EIN-2016_RGB-White01-300x119.png?size=139x55&lossy=0&strip=1&webp=1 139w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="footer-text-wrap">Address: 4 Glasby Square, Retford DN22 6EP / Phone: 01777 802111<div class="footer-email-wrap">Contact us: <a href="mailto:features@eventindustrynews.com">features@eventindustrynews.com</a></div></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/eventindustrynewsuk/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/eventindustrynews/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company/event-industry-news/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/EventNewsBlog" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCizuO_XW57Uq4uUQ9BKdjPA" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></div></div>            </div>
        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                    </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Event Industry News 2020                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->



			<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":1,"name":"Adam Parry","avatar":"695c026427c5239ea3c356e91d4e3cc2"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '17956']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
			

    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        
        uid: 605d1805d946b
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.author-box-wrap {display: flex;}

.author-box-wrap .desc {margin-left: 5% !important; width: 65%;}

.author-box-wrap .desc.td-author-name {margin-top: 0 !important;}

.author-box-wrap > a { width: 30%; }
.author-box-wrap img { width: 100%; }





/* custom responsive css from theme panel (Advanced CSS) */
@media (max-width: 767px) {
.author-box-wrap {display: block;}
.author-box-wrap img {width: 200px;}
.author-box-wrap .desc {width: 100%; margin-left: 0 !important;}

}
</style>

<div class="td-container"><!-- OneTrust Cookies Consent Notice start -->
<script src="https://cookie-cdn.cookiepro.com/consent/a50c9d82-38ff-4c7c-bc7c-7140d1b349fa.js"  type="text/javascript" charset="UTF-8"></script>
<script type="text/javascript">
function OptanonWrapper() { }
</script>
<!-- OneTrust Cookies Consent Notice end -->


<!-- CookiePro Cookies Settings button start -->
<button id="ot-sdk-btn" class="ot-sdk-show-settings"> Cookie Settings</button>
<!-- CookiePro Cookies Settings button end -->

<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/4e8d667d7dc98e1317ddcb208/848d2e35bd792d166129104fa.js");</script>


<!-- Twitter universal website tag code -->
<script>
!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','o21nv');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code -->

<script data-ad-client="ca-pub-7900736285742244" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<script>
  (function(){

    window.ldfdr = window.ldfdr || {};
    (function(d, s, ss, fs){
      fs = d.getElementsByTagName(s)[0];

      function ce(src){
        var cs  = d.createElement(s);
        cs.src = src;
        setTimeout(function(){fs.parentNode.insertBefore(cs,fs)}, 1);
      }

      ce(ss);
    })(document, 'script', 'https://sc.lfeeder.com/lftracker_v1_YEgkB8lv3jW4ep3Z.js');
  })();
</script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KGVB4D');</script>
<!-- End Google Tag Manager -->


<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KGVB4D"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<!-- Pipedrive -->
<script> (function(){ window.ldfdr = window.ldfdr || {}; (function(d, s, ss, fs){ fs = d.getElementsByTagName(s)[0]; function ce(src){ var cs = d.createElement(s); cs.src = src; setTimeout(function(){fs.parentNode.insertBefore(cs,fs)}, 1); } ce(ss); })(document, 'script', 'https://sc.lfeeder.com/lftracker_v1_YEgkB8lv3jW4ep3Z.js'); })(); </script>
<!-- End pipedrive --></div><script type="text/javascript">   function track_load (docloc, doctit) { 
         var trk_sw = escape(screen.width).substring(0, 6); 
         var trk_sh = escape(screen.height).substring(0, 6); 
         var trk_ref = escape(document.referrer).substring(0, 1100); 
         var trk_tit = escape(doctit).substring(0, 200); 
         trk_tit = trk_tit.replace(/\%u00a0/g, ''); 
         trk_tit = trk_tit.replace(/\%u2122/g, ''); 
         trk_tit = trk_tit.replace(/\%u[0-9][0-9][0-9][0-9]/g, ''); 
         var trk_loc = escape(docloc).substring(0, 200); 
         var trk_agn = escape(navigator.appName).substring(0, 100); 
         var trk_lng = window.navigator.userLanguage || window.navigator.language; 
         var trk_agv = escape(navigator.userAgent + '.lfcd' + screen.colorDepth + '.lflng' + trk_lng).substring(0, 1000); 
         var trk_dom = escape(document.domain).substring(0, 200); 
         var trk_user = '81409'; 
         var trk_cookie = ''; 
         var trk_guid = 'xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx'.replace(/[xy]/g, function(c) { 
             var r = Math.random()*16|0, v = c == 'x' ? r : (r&0x3|0x8); 
             return v.toString(16); 
         }); 
         var trk_img = 'https://secure.leadforensics.com/Track/Capture.aspx'; 
         var trk_link = trk_img + '?trk_user=' + trk_user + '&trk_sw=' + trk_sw + '&trk_sh=' + trk_sh + '&trk_ref=' + trk_ref + '&trk_tit=' + trk_tit + '&trk_loc=' + trk_loc + '&trk_agn=' + trk_agn + '&trk_agv=' + trk_agv + '&trk_dom=' + trk_dom + '&trk_guid=' + trk_guid + '&trk_cookie=NA'; 
         var preload = new Image(); 
         preload.src = trk_link; 
     } </script>    <!-- Facebook Pixel Event Code -->
    <script type='text/javascript'>
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script>
    <!-- End Facebook Pixel Event Code -->
    <div id='fb-pxl-ajax-code'></div>		<div id="amp-mobile-version-switcher" hidden>
			<a rel="amphtml" href="https://www.eventindustrynews.com/features/top-virtual-venues-bma-house?amp=1">
				Go to mobile version			</a>
		</div>

				
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.eventindustrynews.com\/features\/top-virtual-venues-bma-house":537196};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/features/top-virtual-venues-bma-house" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://792035.smushcdn.com/1520188/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif?lossy=0&strip=1&webp=1" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Poppins%3A400%2C100%7CPalanquin+Dark%3A400%2C100%7COpen+Sans%3A400%2C600%2C700%2C100%7CRoboto%3A400%2C500%2C700%2C100&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.eventindustrynews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' defer src='https://hb.wpmucdn.com/www.eventindustrynews.com/d18c5987-7e73-4d62-9506-8f3542418b30.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' defer src='https://hb.wpmucdn.com/www.eventindustrynews.com/5fae6ed4-3293-449d-ac43-5af0a94e408d.js' id='underscore-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.eventindustrynews.com/46af7e3e-f016-499c-8df1-e195eb067922.js' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' defer src='https://hb.wpmucdn.com/www.eventindustrynews.com/c2b79acc-2fbc-41cf-89b8-9695e72498ff.js' id='td-site-min-js'></script>
<script type='text/javascript' defer src='https://hb.wpmucdn.com/www.eventindustrynews.com/e238e668-c0fe-459c-90c7-12b1e85e9652.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.eventindustrynews.com/1f3406a2-0ee8-4074-8cb8-eacd87827b66.js' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' defer src='https://hb.wpmucdn.com/www.eventindustrynews.com/111f45f1-c477-49c7-bad8-2820f2e70542.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.eventindustrynews.com/6a066059-c227-45b3-8132-0578f83d6216.js' id='remote_sdk-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' defer src='https://hb.wpmucdn.com/www.eventindustrynews.com/51fea372-ec7a-438d-aa90-b61030734aef.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>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</script>

<!-- JS generated by theme -->

<script>
    
</script>

<script src='https://stats.wp.com/e-202112.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.5',blog:'144535413',post:'537196',tz:'0',srv:'www.eventindustrynews.com'} ]);
	_stq.push([ 'clickTrackerInit', '144535413', '537196' ]);
</script>

</body>
</html>